TechnoWikia
All About Technology

Latest Mikrotik WMS Auto Login Script 2021

WMS users will know that using the venue’s wifi once a day has to re-login to be able to connect. It looks trivial right? Just login once, why bother?. Yes, if you are just an ordinary user like me. But what if you’re a RT RW NET player?. Must be annoying.

Latest Mikrotik WMS Auto Login Script 2021

Imagine if you are out of the house while the internet connection requires re-login. The customers must have been chuckling. So to be safe, RT RW NET players prefer Indihome. But unfortunately Indihome implements the FUP system. You know, every time you go to the end of the month the connection is slow because its usage exceeds FUP.

Before this, it was good, there was still SSID [email protected] Stay connected and sleep well. But it’s a shame, Telkom intends to delete this [email protected] SSID.

Then can we connect only once using the SSID Venue?. You can use the auto login script.

Script Auto Login WMS Di Mikrotik

Yes, we have to use Mikrotik (if you have read this article, you must have used it, right?). So with this script, every time the proxy disconnects, it will re-login automatically.

Please copy this script in notepad first so it’s easy to edit

 # Daftar Variable :local user "XXX" :local pass "XXX" :local gwid "XXX-XX-XXX" :local ether "XXX" :local wlan "XXXXXXXXXX/TLK-WIXXXXXXXX-000X:XXXXX" :local wms "@wms.XXXXXXXXXX.000" :local redirect "https://www.livescore.com" # Akhir Variable  :log info "Menjalankan Auto Login ..." :local ip [/ip address get [/ip address find interface="$ether"] address]; :local ip [put [:pick $ip 0 [:find $ip "/"]]]; :if ([:len $ip] = 0) do={ :log error ("Interface $ether tidak mendapatkan alamat ip --- mencoba mendapatkan..."); /ip dhcp-client release [find interface="$ether"]; }; delay 1s  :local mac [/interface get [find name="$ether"] mac-address]; :local gateway [/ip dhcp-client get [find interface="$ether"] gateway]; :log warning "IP Address     : $ip" :log warning "MAC Address : $mac" :log warning "IP Gateway    : $gateway"  :log info "Menghubungkan ..."  :local num1 [:pick [/system clock get time] 0]  :local num2 [:pick [/system clock get time] 1]  :local num3 [:pick [/system clock get time] 3]  :local num4 [:pick [/system clock get time] 6]  :local char1 [:pick "abcdefghijklmnopqrstuvwxyz" "$num1$num2"] :local char2 [:pick "abcdefghijklmnopqrstuvwxyz" "2$num2"] :local char3 [:pick "abcdefghijklmnopqrstuvwxyz" "1$num4"] :local user "$user.$char3$char1$char2$wms"  :do { :tool fetch mode=https http-header-field="Content-Type: application/x-www-form-urlencoded; charset=UTF-8,User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36,Referer: https://welcome2.wifi.id/login/?gw_id=$gwid&client_mac=$mac&wlan=$wlan&sessionid=XXXXXXXXXXXXXXXX-XXXXXXXX&redirect=$redirect" http-method=post http-data="username=$user&password=$pass" url="https://welcome2.wifi.id/wms/auth/authnew/autologin/quarantine.php\?ipc=$ip&gw_id=$gwid&mac=$mac&redirect=$redirect&wlan=$wlan" dst-path=wms.txt; :if ([/ping address=$gateway interface="$ether" count=2] = 0) do={ :log error "Login gagal... "; /ip dhcp-client release [find interface="$ether"]; } :if ([/ping address=$gateway  interface="$ether" count=2] != 0) do={ :log info "Login SUKSES..." :local iRes [/file get wms.txt contents]; :log warning $iRes delay 1s :file remove wms.txt } } #:log warning "$user.$char3$char1$char2$wms" 

Also copy this schedule script,

 :if ([:ping 8.8.8.8 interface=XXX count=5]=0) do={:system script run wms;} 

How to edit WMS Auto Login Script

Before installing the autologin script, we first edit the script that was copied earlier.

  1. Connect to your Venue SSID
  2. After connecting and entering the login page, don’t log in first. On the login page, please press the combination CTRL + U or you can right-click on the login page and select View page source. Then a new tab will open
  3. Please edit the script
    :local user “XXX : edit XXX with your login username
    :local pass “XXX: edit XXX with your login password
    :local gwid “XXX-XX-XXX : on the page that opens when CTRL + U please press CTRL + F and type gwid later replace XXX-XX-XXX with your gwid.
    :local ether “XXX : edit with your proxy wlan interface to capture the SSID of the venue. For example, have wlan2
    :local wlan “XXXXXXXXXX/TLK-WIXXXXXXXX-000X:XXXXX : same as edit gwid, press CTRL+F and type wlan
    :local wms “@wms.XXXXXXXXXX.000 : tekan CTRL+F and type @wms later please replace it with your @wms
    :local redirect “https://www.livescore.com” : No need to edit, in my opinion the fastest thing is to use this site.
    sessionid=XXXXXXXXXXXXXXXX-XXXXXXXX :this is obtained at your wms login addressto edit the schedule script :if ([:ping 8.8.8.8 interface=XXX count=5]=0) do={:system script run wms;} : please fill in XXX with your mikrotik wlan interface which is to capture the wifi signal.

How to Install the WMS Venue Auto Login Script on Mikrotik

  1. Login to your winbox
  2. Go to System -> Scripts
    then press the + button and enter the script

     

  3. If it’s now just set the schedule by going to System -> Schedule
    fill it like this

  4. Done

How?. Is it easy to apply the WMS venue auto login script on Mikrotik? Fill it like this

Comments are closed.

This website uses cookies to improve your experience. We'll assume you're ok with this, but you can opt-out if you wish. Accept Read More

%d bloggers like this: